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Windows/Linux Équivalent Mac Effet

Sélection de menu 
Outils > Options

LibreOffice > Préférences Accès aux options de paramétrage

Clic droit ⌘+clic Ouvre un menu contextuel

Ctrl (Contrôle) ⌘ (Commande) Utilisé avec d'autres touches

F5 Maj+⌘+F5 Ouvre le Navigateur

F11 ⌘+T Ouvre la fenêtre Styles & Formatage
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Qu’est-ce que Math ?

Math est le module de LibreOffice pour écrire des équations mathématiques et chimiques. Il est en 
général utilisé comme éditeur d’équation pour les documents texte, mais il peut être utilisé avec 
d’autres types de documents ou comme module en soi. Lorsqu’il est utilisé dans Writer, l’équation 
est considérée comme un objet à l’intérieur du document texte.

Note
L’éditeur d’équation est utilisé pour écrire des équations sous forme symbolique 
comme dans l’équation 1. Si vous cherchez à évaluer une valeur numérique, 
consultez le Guide Calc.

df (x )
dx

=ln(x )+ tan−1(x2) (1)

ou

NH3+H2 O⇌NH4
++OH−

Pour commencer

Vous pouvez créer une équation (formule) comme un document séparé ou vous pouvez l’insérer 
dans un document Writer ou dans un autre module LibreOffice.

Créer une équation comme un document séparé
Pour créer une équation en tant que document séparé, ouvrez le module Math de LibreOffice avec 
une de ces méthodes :

• Dans la barre de menu, sélectionnez Fichier > Nouveau > Formule.

• Dans la barre d’outils standard, cliquez sur le triangle à gauche de l’icône  Nouveau et 
sélectionnez Formule.

• À partir du centre de démarrage, cliquez sur Formule.

Un document formule vide s’ouvre comme sur la Figure 1.

Figure 1 : Un document formule vide
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La zone supérieure est la fenêtre de visualisation, où l’équation va apparaître pendant et après 
l’écriture. La zone inférieure est l’éditeur d’équation, où le code de l’équation est tapé. La fenêtre 
flottante Éléments va aussi apparaître. 

Insérer une formule dans un document Writer
Pour insérer une formule dans un document Writer, ouvrez le document et sélectionnez dans la 
barre de menu Insertion > Objet > Formule.

Par défaut, l’éditeur d’équation apparaît en bas de la fenêtre Writer, ainsi que la fenêtre flottante 
Éléments.  Une boite avec une bordure grise va également apparaître dans votre document,  à 
l’endroit où la formule sera affichée, comme le montre la Figure 2.

Figure 2: Éditeur d’équation, fenêtre Éléments et placement de l’équation dans Writer

Astuce Si la fenêtre Éléments est absente, faîtes-la apparaître avec Affichage > Éléments.

Quand vous avez fini de taper la formule, vous pouvez fermer l’éditeur en appuyant sur la touche 
Échap. ou en cliquant hors de la formule dans le document principal. Un double-clic sur l’équation 
ouvrira à nouveau l’éditeur, pour pouvoir modifier la formule.

Les formules sont insérées en tant qu’objets OLE. Dans un document Writer, la formule est ancrée 
par défaut comme caractère. Elle est ainsi incluse dans la continuité du texte. Comme pour tout 
objet OLE, vous pouvez modifier l’ancrage et rendre la formule flottante. Dans les documents Calc, 
Impress et Draw, les formules sont insérées comme objets OLE flottants.

Si  vous avez régulièrement  besoin  d’insérer  des  formules,  il  est  conseillé  d’ajouter  le  bouton 
Formule à  la  barre  d’outils  Standard ou  de  créer  un  raccourci  clavier  (voir  la  section 
Personnalisations du Guide Math).

Écrire une formule

L’éditeur d’équation utilise un langage de balisage pour afficher les formules. Par exemple, %bêta 
créer le caractère grec bêta ( β ). Ce balisage est conçu pour être lu comme de l’anglais (ou du 
français pour les caractères grecs et spéciaux) autant que possible. Par exemple,  a over b 

donne une fraction : 
a
b

 (over signifiant au-dessus en anglais).
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Vous pouvez écrire une formule de trois manières :

• Sélectionnez un symbole de la fenêtre Éléments.

• Cliquez-droit  dans  l’éditeur  d’équation  et  sélectionnez  le  symbole  à  partir  du  menu 
contextuel.

• Tapez le balisage dans l’éditeur d’équation.,

Le menu contextuel et la fenêtre Éléments insèrent le balisage correspondant à un symbole. Cela 
permet d’apprendre simplement le balisage de LibreOffice Math.

Note
Cliquez sur le corps du document pour quitter l’éditeur de formule.

Double-cliquez sur une formule pour retourner dans une formule.

La fenêtre Éléments
La méthode la plus simple pour écrire une formule est la fenêtre Éléments.

Figure 3 : Les symboles sont répartis en catégories

La fenêtre Éléments est divisée en deux parties principales :

• Le haut présente les catégories de symboles. Cliquez sur celles-ci pour changer de liste 
de symboles.

• Le bas présente les symboles disponibles dans la catégorie courante.

Astuce Vous pouvez masquer ou afficher la fenêtre Éléments avec Affichage > Éléments.

Exemple 1 : 5×4

Dans cet exemple, nous allons entrer une formule simple : 5×4 . Dans la fenêtre Éléments :

1) Sélectionnez le bouton en haut à gauche de la section des catégories (haut).

2) Cliquez sur le symbole multiplication.
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Figure 4 : Sélection du symbole multiplication 

Quand le symbole multiplication est sélectionné dans la fenêtre Éléments, deux actions ont lieu :

• L’éditeur d’équation affiche le balisage : <?> times <?>

• Le corps du document affiche une boîte grise comme ceci : ❑×❑

Figure 5 : Résultat de la sélection du symbole multiplication 

Les  symboles  <?> affichés  Figure  5 sont  les  emplacements  que vous pouvez  remplacer  par 
d’autres textes, par exemple 5 et 4. L’équation va se mettre à jour automatiquement, et le résultat 
devrait ressembler à la Figure 6.

Astuce
Lors de l’édition d’une formule, les places réservées sont marquées par des carrés 
dans les formules et des <?> dans la fenêtre de commande. Utilisez F4 et Maj+F4 
pour naviguer entre ces emplacements.

Figure 6 : Résultat après avoir tapé 5 et 4 à côté de l’opérateur multiplication
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Astuce
Pour éviter la mise à jour automatique de l’équation, sélectionnez Affichage 
>Rafraîchir automatiquement l’affichage. Pour rafraîchir une formule 
manuellement, appuyez sur F9 ou sélectionnez Affichage > Actualiser.

Menu clic-droit (contextuel)
Une autre façon d’accéder aux symboles mathématiques est de faire un clic-droit dans l’éditeur 
d’équation. Un menu contextuel s’affiche alors comme sur la  Figure 7. Les entrées de ce menu 
correspondent à ceux de la fenêtre Éléments, avec quelques commandes supplémentaires.

Figure 7 : Menu contextuel par clic-droit

Note
Ni la fenêtre Éléments, ni le menu contextuel ne contiennent la liste complète des 
commandes. Quelques commandes non usuelles nécessitent de taper leurs balises. 
L’annexe du Guide Math propose une liste complète des commandes. 

Balisage
Vous pouvez taper directement le  balisage dans l’éditeur d’équation. Par exemple, vous pouvez 
taper  5 times 4 pour obtenir  5×4 . Si vous connaissez le balisage, c’est la méthode la plus 
rapide pour entrer une formule.

Astuce Le balisage correspond à l’écriture en anglais des formules.

Le  tableau  ci-dessous  présente  une  liste  rapide  des  équations  communes  et  leur  balisage 
respectif. 

Affichage Commande Affichage Commande

a=b a = b √a sqrt {a}

a2 a^2 an a_n

∫ f (x )dx int f(x) dx ∑ an
sum a_n
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Affichage Commande Affichage Commande

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Caractères grecs
Les  caractères  grecs  ( α ,β ,γ ,θ ,  etc.)  sont  courants  dans  les  formules  mathématiques.  Ces 
caractères  ne  sont  pas  disponibles  dans  la  fenêtre  Éléments  ou  par  le  menu  contextuel. 
Heureusement, le balisage des caractères grecs est simple : tapez un symbole % suivi par le nom 
du caractère en français.

• Pour écrire un caractère en minuscule, tapez le nom du caractère en minuscule.

• Pour écrire un caractère en majuscule, tapez le nom du caractère en majuscule.

• Pour écrire le caractère en italique, insérez un i entre le % et le nom du caractère.

Un tableau complet  des caractères grecs est  fourni  en annexe du Guide Math. Le tableau ci-
dessous présente quelques exemples.

Minuscule Majuscule Minuscule italique Majuscule italique

%alpha → α %ALPHA → Α %ialpha → α %iALPHA → Α

%bêta → β %BÊTA → Β %ibêta 
→ %ibêta

%iBÊTA 
→ %iBÊTA

%gamma → γ %GAMMA → Γ %igamma → γ %iGAMMA → Γ

%psi  → ψ %PSI  → Ψ %ipsi  → ψ %iPSI  → Ψ

%phi  → ϕ %PHI  → Φ %iphi  → ϕ %iPHI  → Φ

%thêta → θ %THÊTA → Θ %ithêta → θ %iTHÊTA
→ %iTHÊTA

Une autre façon d’entrer des caractères grecs est d’utiliser la fenêtre du catalogue de symboles. 
Sélectionnez Outils > Catalogue. Cette fenêtre est présentée Figure 8. Sous Jeu de symboles, 
sélectionnez Grec et double-cliquez sur la lettre grecque de la liste. La balise du nom du caractère 
est indiquée sous la fenêtre de liste.

Figure 8 : Catalogue des symboles utilisés pour entrer les caractères grecs 
et quelques symboles spéciaux
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Exemple 2 : π ≃ 3,14159

Pour cet exemple nous supposerons que :

• Vous voulez entrer la formule ci-dessus (la valeur de pi arrondie à 5 décimales).

• Vous connaissez le nom du caractère grec (pi).

• Mais vous ne connaissez pas la balise associée avec le symbole ≃ .

Étape 1 : Tapez % suivi du texte pi. Le caractère grec π s’affiche.

Étape 2 : Ouvrez la fenêtre Éléments (Affichage > Éléments).

Étape 3 : Le symbole ≃  est une relation, donc cliquez sur la catégorie Relations. En maintenant 
la souris sur ce bouton, vous voyez l’info-bulle Relations (Figure 9).

La Figure 10 montre la fenêtre Éléments après avoir cliqué sur le bouton Relations. Le symbole 
recherché est entouré.

Figure 9 : L’info-bulle indique le 
bouton Relations

Figure 10 : Après sélection de Relations

Étape 4 : Cliquez sur le symbole a ≃ b. L’éditeur d’équation montre maintenant le balisage  %pi<?
> simeq <?>.

Étape 5 : Effacez le texte <?>, appuyez sur F4, puis tapez 3,14159. Le balisage complet est %pi 
simeq 3,14159. La Figure 11 présente le résultat.

Figure 11 : Résultat final
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Modifier une formule
Vous pouvez modifier une formule à tout moment. Pour basculer en mode édition, double-cliquez 
sur une formule.

Pour atteindre la section appropriée du balisage, vous pouvez :

• Dans l’éditeur d’équation, cliquer sur la position.

• Sélectionner une zone du balisage que vous souhaitez modifier.

• Cliquer sur un élément de la zone d’aperçu ; le curseur va automatiquement se positionner 
au point correspondant de l’éditeur d’équations.

• Double-cliquer sur un élément de la zone de l’aperçu ;  la section correspondante dans 
l’éditeur d’équations sera sélectionnée.

Dans la fenêtre du module Math indépendant (Figure 1), pour pouvoir travailler dans la zone du 
dessus (aperçu), le curseur de formule doit être activé. Utilisez le bouton Curseur de formule dans 
la barre d’outils Outils.

Vous pouvez modifier une équation en écrasant le texte sélectionné ou en insérant des nouveaux 
codes de balisage à la position du curseur.

Positionnement dans les formules

La partie la plus difficile lors de l’utilisation de LibreOffice Math provient de l’écriture de formules  
complexes. Cette section donne quelques conseils.

Les accolades sont vos amies
LibreOffice Math n’a aucune connaissance de la priorité des opérateurs. Vous devez utiliser des 
accolades ou des parenthèses pour fixer l’ordre des opérations explicitement. Voyez les exemples 
suivants :

Balisage Résultat Balisage Résultat

2 over x + 1
2
x
+1 2 over {x + 1}

2
x+1

– 1 over 2   
−1
2

– {1 over 2}   −
1
2

Dans le premier exemple, Math a reconnu que le 2 avant et le x après le over appartiennent à la 
fraction et les a représentés ainsi. Si vous voulez x+1 plutôt que x au dénominateur, vous devez 
les encadrer d’accolades de façon à les placer ensemble.

Dans le second exemple, Math a reconnu le signe moins en tant que préfixe de 1 et l’a ainsi placé 
au numérateur de la fraction. Si vous voulez montrer que la fraction entière est négative, avec le 
signe moins devant la fraction, vous devez encadrer la fraction d’accolades pour signifier à Math 
que la fraction est un ensemble.

Les accolades appartiennent uniquement au balisage du code et ne sont pas visibles. Si vous 
souhaitez utiliser des accolades dans une formule, utilisez les commandes lbrace et rbrace.

Comparez les exemples suivants :
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Balisage Résultat Balisage Résultat

x over {–x + 1}
x

−x+1
x over lbrace –x + 1 
rbrace

x
{−x +1}

Faire de grandes parenthèses (pour les matrices)
Commençons par présenter la commande pour les matrices : matrix.

Balisage Résultat

matrix { a # b ## c # d } a b
c d

Note Les lignes sont séparées par deux # et chaque élément d’une ligne par un #.

Le premier problème rencontré avec les matrices est que les parenthèses ne s’adaptent pas à la 
taille de la matrice :

Balisage Résultat

(  matrix { a # b ## c # d }  ) (a b
c d

)

LibreOffice  Math  dispose  de  parenthèses  ajustables :  les  parenthèses  s’agrandissent  pour 
s’adapter  à  la  taille  de  leur  contenu.  Utilisez  les  commandes  left( et  right) pour  obtenir  les 
parenthèses ajustables.

Balisage Résultat

left(  matrix { a # b ## c # d }  right) (a b
c d)

Astuce
Utilisez left[ et right] pour obtenir des crochets. La liste des parenthèses utilisables 
est donnée dans le Guide Math en annexe.

Ces parenthèses ajustables sont bien sûr utilisables avec n’importe quel élément autre que les 
matrices : fraction, racine, etc.

Parenthèses isolées ou dépareillées
Math s’attend que pour chaque parenthèse ouvrante, il y aura une parenthèse fermante. Si vous 
oubliez une parenthèse, Math insère un point d’interrogation rouge à l’envers ¿ pour la parenthèse 
manquante.  Celui-ci  disparaît  dès  que  les  parenthèses  sont  appariées.  Parfois  l’oubli  d’une 
parenthèse  détruit  toute  la  structure  de  la  formule.  Cependant,  une  parenthèse  dépariée  est 
parfois nécessaire. Deux options sont alors possibles :

Avec des parenthèses non ajustables, faîtes précéder par une barre oblique inversée (backslash) 
\ pour indiquer que le caractère suivant ne doit pas être considéré comme une parenthèse mais 
un caractère littéral.  Ainsi  l’intervalle semi-ouvert  [a;b[ est représenté par  \[a;b\[  — vous 
pouvez comparer avec le balisage  [a;b[. Vous pouvez aussi mettre entre guillemets droits les 
parenthèses pour qu’elles soient considérées comme du texte : "["a;b"[".
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Les parenthèses ajustables peuvent  aussi  être dépariées.  Le même intervalle  semi-ouvert  est 
représenté par :

left [ a; b right [
Pour les parenthèses ajustables, vous pouvez également utiliser la balise none pour remplacer la 
seconde parenthèse non existante :

∣x∣={ x pour x≥0
−x pour x<0

peut être représenté par : 

abs x = left lbrace stack {x "pour" x >= 0 # -x "pour" x < 0} right 
none

Reconnaissance des fonctions dans Math
Dans l’installation par défaut, Math affiche les variables en italique. Si vous tapez une fonction, 
Math habituellement la reconnaît et l’affiche normalement. Si Math ne reconnaît pas une fonction 
(une liste des fonctions reconnues est disponible en annexe du Guide Math), vous pouvez forcer 
Math à la reconnaître. Tapez la balise func avant la fonction, et le texte qui suit sera connu comme 
une fonction.

Certaines fonctions reconnues par Math nécessitent d’être suivies de nombres ou de variables. S’il 
n’y en a pas, Math affiche un point d’interrogation rouge à l’envers ¿ à leur place, que vous pouvez 
supprimer en corrigeant la formule : tapez une variable ou un nombre, ou une paire d’accolades 
vide { }.

Astuce Pour naviguer entre les différentes erreurs, utilisez F3 et Maj+F3.

Équations sur plusieurs lignes

Supposez que vous voulez écrire une équation sur plusieurs lignes, par exemple : x=3
y=1

Votre  première  réaction  serait  de  simplement  appuyez  sur  la  touche  Entrée.  Cependant  en 
appuyant sur la touche Entrée, bien que le balisage passe à la ligne suivante, l’équation résultante 
ne  le  fait  pas.  Vous  devez  taper  la  balise  newline explicitement,  comme l’illustre  le  tableau 
suivant :

Balisage Résultat

x = 3

y = 1
x=3 y=1

x = 3 newline

y = 1

x=3
y=1

Si vous souhaitez poursuivre le calcul sur une nouvelle ligne sans écrire une nouvelle équation 
complète, cela n’est pas possible directement, car Math attend un terme de part et d’autre du signe 
égal. Vous pouvez les remplacer par :

• des guillemets vides "". Cela va automatiquement aligner la ligne à gauche ;

• des accolades vides { }. La ligne sera centrée.

L’alignement des signes égal les uns au-dessus des autres est décrit page 17.
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De même l’espacement entre les éléments d’une formule n’est pas géré par les espaces tapés 
dans le code.  Il  faut  pour  cela utiliser  les balises d’espace :  ` (accent  grave) pour une petite 
espace, ~ pour une grande espace. Une autre solution est d’ajouter les espaces entre guillemets 
droits pour être comme du texte. Les balises d’espace en fin de formule sont par défaut ignorées.

Ajouter des limites aux signes somme ou intégrale
Les balises de type sum et int (voir la liste complète en annexe du Guide Math) peuvent (de façon 
optionnelle) utiliser les paramètres from et to. Ces derniers sont utilisés pour les limites inférieure 
et supérieure respectivement. Ces paramètres peuvent être utilisés séparément ou ensemble. 

Balisage Résultat

sum from k = 1 to n a_k ∑
k=1

n

ak

int from 0 to x f(t) dt

ou 

int_0^x f(t) dt
∫
0

x

f (t )dt  ou ∫0

x
f (t )dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Écrire une dérivée
Écrire des dérivées se résume principalement à : dîtes à LibreOffice que c’est une fraction.

Autrement dit, vous devez utiliser la commande  over. Combinez ceci avec la lettre  d (pour une 
dérivée  totale)  ou  la  commande  partial (pour  une  dérivée  partielle)  pour  obtenir  l’effet  d’une 
dérivée.

Note Notez l’utilisation des accolades pour écrire les dérivées partielles.

Balisage Résultat

{df} over {dx} df
dx

{partial f} over {partial y}
∂ f
∂ y

{partial^2 f} over {partial t^2}
∂2 f

∂t 2

Pour écrire les noms de fonction avec les primes, comme habituellement en notation scolaire, vous 
devez d’abord ajouter  ces signes au catalogue.  L’utilisation de l’apostrophe ou des guillemets 
droits est inesthétique. Voir la section Personnaliser le catalogue page 23.
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Caractères du balisage en tant que caractères normaux
Les caractères utilisés comme balise ne peuvent pas être tapé directement comme caractères 
normaux. Les caractères concernés sont : %, {, }, &, |, _, ^ et ". Par exemple vous ne pouvez pas 
taper 2% = 0,02 ou 1" = 2,56cm. Deux méthodes sont disponibles pour dépasser cette limitation :

• Utiliser les guillemets droits pour marquer le caractère comme texte, par exemple 2"%"= 
0,02. Cela n’est bien sûr pas utilisable pour les guillemets droits eux-mêmes.

• Ajouter le caractère au catalogue comme indiqué à la section  Personnaliser le catalogue 
page 23. 

Dans quelques cas, vous pouvez utiliser des commandes :

• lbrace et rbrace donnent des accolades {}.

• mline donne une ligne verticale, par exemple (2 mline 3) pour (2∣3)

La conversion avec une référence de caractère comme dans le langage html ou l’utilisation d’un 
caractère d’échappement n’est pas possible avec Math.

Texte dans une formule
Pour inclure un texte dans une formule, il suffit de l’entourer de guillemets droits :

abs x = left lbrace matrix {x # "pour " x >= 0 ## -x # "pour " x < 0} 
right none

∣x∣={ x pour x≥0
−x pour x<0

Tous  les  caractères,  à  l’exception  des  guillemets  droits,  sont  autorisés  dans  un  texte. 
Malheureusement la boite de dialogue d’insertion des caractères spéciaux n’est pas disponible 
dans Math. En cas de nécessité, il est possible d’écrire le texte dans Writer et de le copier dans 
l’éditeur d’équation par le presse-papier. De cette manière, des guillemets français peuvent être 
insérés comme ci-dessous :

Figure 12 : Guillemets français insérés par copier-coller depuis Writer.

Le texte s’affiche dans la police sélectionnée par la liste Texte dans le dialogue Polices (voir infra 
la section Modifier la police page 18). Pour utiliser une police du bas de la fenêtre de la Figure 16, 
utilisez un balisage font serif, font sans ou font fixed avant le texte.

Par défaut le texte est aligné à gauche. Vous pouvez changer l’alignement avec alignc ou alignr. 

Les balises ne sont pas interprétées à l’intérieur d’un texte. Utilisez les guillemets pour interrompre 
le texte et pour utiliser du balisage de formatage.

"Dans les triangles " color blue bold "isocèles" ", les angles de la 
base sont égaux" 
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Dans les triangles isocèles, les angles de la base sont égaux

Alignement des équations sur leur signe égal
LibreOffice Math ne dispose pas d’une commande pour aligner les équations sur un caractère 
particulier, mais vous pouvez utiliser une matrice pour le faire, comme dans cet exemple :

Balisage Résultat

matrix{

   alignr x+y # {}={} # alignl 2 ##

   alignr x   # {}={} # alignl 2-y

}

x+ y = 2
x = 2− y

Les accolades vides autour des = sont nécessaires car = est un opérateur binaire et nécessite une 
expression de chaque côté.

Vous pouvez réduire l’espace autour des = si  vous changez l’espacement  inter-colonne de la 
matrice :

1) Dans l’éditeur d’équation, sélectionnez Format > Espacement dans la barre de menu.

2) Dans  le  dialogue  d’espacement  (Figure  13),  cliquez  sur  le  bouton  Catégorie et 
sélectionnez Matrices dans menu déroulant.

3) Entrez 0% pour l’espacement entre les colonnes et cliquez sur OK.

Figure 13 : Modification de l’espacement dans une matrice

Modification de l’apparence des formules

Modifier la taille de police
C’est une des questions les plus courantes au sujet de LibreOffice Math. La réponse est simple, 
mais peut-être pas si intuitive :

1) Dans l’éditeur de formule, sélectionnez le menu Format > Taille de police.

2) Sélectionnez une taille de police plus grande avec Taille de base (entrée tout en haut).
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Figure 14 : Modifier la taille de base (en haut) pour agrandir la formule

Le résultat de ce changement est illustré sur la Figure 15.

Figure 15 : Résultat du changement de la taille de base de la police

Note

Le changement de taille de police ne s’applique que pour la formule courante. Pour 
changer la taille de façon permanente, cliquez sur le bouton Par défaut puis OK. Un 
changement de la taille par défaut pourra, par exemple, rendre votre travail bien plus 
facile lorsque vous préparez une présentation longue et que vous voulez toutes les 
formules en taille de base 28pt. Cependant, n’oubliez pas de ramener la taille de 
base à sa valeur originale à la fin de votre travail.

Attention : cela n’affecte que la formule courante et les prochaines formules que 
vous créerez. Pour modifier toutes les formules déjà créées dans un document, il 
faut utiliser une macro (voir la section sur les macros du Guide Math).1

La taille d’un sous ensemble de caractères dans une formule peut se changer avec la commande 

size. Exemple : b size 5{a} : b a . Avec la fenêtre Éléments, l’avant dernière icône  de 
l’onglet  Attributs permet d’obtenir la commande  size. La valeur après  size peut être absolue 
(une valeur numérique) ou relative par rapport au contexte (par défaut la taille de base) : +6, -3, 
/2,  ou  *2 par  exemple.  L’emploi  de  valeur  numérique  décimale  nécessite  d’utiliser  un  point 
comme séparateur décimal.

Modifier la police
Les polices utilisées dans Math peuvent être modifiées à l’aide du menu  Format > Polices.  La 
section Polices des formules (Figure 16) fait référence aux quatre éléments de formule spécifiés. 
La police pour les opérateurs, les relations et les parenthèses n’est pas affectée, car ces éléments 
viennent  normalement  de  la  police  OpenSymbol.  De  la  même  façon,  les  éléments  issus  du 
catalogue  (cf.  Personnaliser  le  catalogue page  23)  continuent  d’être  affichés  dans  la  police 
spécifiée.

1 http://wiki.documentfoundation.org/FR/FAQ/Math/102 
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Figure 16 : Dialogue des polices

La section  Polices personnalisées sélectionne la police qui sera utilisée lorsque le balisage font 
serif, font sans ou font fixed est spécifié.

Pour modifier une police, cliquez d’abord sur le bouton Modifier :

Figure 17 : Bouton Modifier

Sélectionnez le type de police à modifier. Le dialogue Polices s’ouvre, montrant toutes les polices 
disponibles dans le système.

Figure 18 : Dialogue des polices
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Si vous tapez un premier caractère dans la boite d’entrée du haut, la liste va sauter directement 
jusqu’à cette lettre. Avec quelques caractères supplémentaires, vous pouvez spécifier la police 
exacte recherchée. Si vous ne connaissez pas son nom, utilisez l’ascenseur pour balayer la liste. 
Cliquez sur un nom pour avoir un aperçu dans la zone du bas.

Comme les variables devraient être en italique, assurez-vous que la case Italique est bien cochée. 
Pour  les autres éléments,  il  convient  de laisser la  forme basique (Roman).  Le style peut  être 
facilement modifié dans la formule elle-même à l’aide des balises italic ou bold (gras) pour activer 
ces caractéristiques et nitalic ou nbold pour les annuler.

Quand une nouvelle police est sélectionnée pour une formule, l’ancienne police reste disponible 
dans la liste avec la nouvelle, et peut être à nouveau sélectionnée. Ceci ne dure que le temps de 
la session ; l’ancienne police n’est pas stockée de façon permanente.

Vous pouvez choisir n’importe quelle police, mais si vous échangez des documents, vous devriez 
choisir des polices également présentes sur l’ordinateur de votre collègue.

Modifier la couleur
La commande color permet de changer la couleur d’une sous formule : color red ABC donne 

ABC . Il y a 8 couleurs différentes à choisir parmi : white, black, cyan, magenta, red, blue, 
green, yellow (pour blanc, noir, bleu clair, violet, rouge, bleu, vert, jaune).

Vous pouvez attribuer une couleur à une sous-formule entière si vous la regroupez avec { } ou 
autres parenthèses. Par exemple : A B color green {C D} E pour avoir A BC D E .

Quand plusieurs couleurs sont appliquées, celles qui sont le plus à l’intérieur prennent le dessus 
comme dans cet exemple : color blue {A B color yellow C D} pour avoir A BC D .

Vous ne pouvez pas sélectionner la couleur du fond, il est toujours transparent dans une formule 
Math. La couleur de fond de la formule complète est donc la couleur de fond du document ou du 
cadre (par exemple un document texte).  Dans  Writer,  les propriétés d’objet (clic droit  >  Objet) 
permettent de choisir une couleur d’arrière-plan pour l’ensemble de la formule (voir  Arrière-plan,
bordures et taille page 23).

Les formules dans Writer

Numérotation des équations
La numérotation des équations est une des meilleures fonctionnalités cachées de LibreOffice. Les 
étapes sont simples mais peuvent paraître obscures :

1) Dans Writer, démarrez une nouvelle ligne, ou laissez une espace à la fin de votre texte.

2) Tapez nf et appuyez sur F3.

Les caractères nf sont remplacés par une équation numérotée :

E=mc 2 (2)

Vous pouvez maintenant double cliquer sur la formule pour l’éditer. Par exemple, voici la fonction 
zêta de Riemann :

ζ(z)=∑
n=1

∞ 1

nz (3)
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Vous pouvez faire référence à cette équation (« comme le montre l’équation (2) ») en suivant ces 
étapes dans Writer :

1) Sélectionnez le menu Insertion > Renvoi.

2) Dans l’onglet Renvois (Figure 19), sous Type de champ, sélectionnez Texte.

3) Sous Sélection, sélectionnez le numéro d’équation. 

4) Sous Insérer une référence à, sélectionnez Référence.

5) Cliquez sur Insérer.

C’est  fait !  Si  par  la  suite,  vous  insérez  de  nouvelles  équations  dans  votre  document  avant 
l’équation référencée, toutes les équations vont être automatiquement renumérotées et les renvois 
seront mis à jour.

Astuce
Pour insérer le numéro d’équation sans les parenthèses, sélectionnez Numérotation 
à la place de Référence sous Insérer une référence à.

L’AutoTexte inséré à la suite de la procédure décrite ci-dessus consiste en un tableau 1x2. La 
cellule de gauche contient la formule et celle de droite le numéro. Le numéro est un compteur 
auto-incrémenté nommé  Texte. Vous pouvez éditer cet AutoTexte si par exemple vous préférez 
des crochets plutôt que des parenthèses ou si vous préférez que la formule et le numéro soient 
séparés par une tabulation plutôt que dans un tableau. Reportez-vous à la section Utilisation des 
AutoTextes au chapitre 3 du Guide Writer (Travail avec du texte).

Figure 19 : Insertion d’un renvoi d’un numéro d’équation
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Position
Par défaut une formule est ancrée Comme caractère dans un document Writer. Mais comme pour 
tout autre objet OLE, vous pouvez modifier le mode d’ancrage pour positionner la formule où vous 
voulez. Pour plus de détails, voir le chapitre 11 du guide Débuter avec LibreOffice (Les graphiques, 
la Gallery et l’outil Fontwork).

Par  défaut,  les  objets  formules  ancrés  Comme  caractère,  sont  automatiquement  alignés 
verticalement sur la ligne de base du texte les entourant. Pour aligner manuellement la formule, 
sélectionnez le menu Outils > Options > LibreOffice Writer > Aide au formatage et décochez 
l’option Alignement sur la ligne de base Math. Ce paramétrage est enregistré dans le document 
courant et s’applique à toutes les formules de ce document. Les nouveaux documents utilisent le 
réglage courant de ce dialogue.

Espacement
Un objet Math inséré a des marges à gauche et à droite pour le séparer du texte l’entourant. Si 
vous n’en voulez pas, il est préférable de modifier le style de cadre pour les formules, car cela 
s’appliquera simultanément sur toutes les formules existantes du document, ainsi que celles qui 
seront insérées. Suivez ces étapes :

1) Affichez le styliste par la touche F11. Le dialogue Styles et formatage s’ouvre.

2) Cliquez sur le bouton Styles de cadre.

3) Cliquez-droit sur le style de cadre Formule.

4) Sélectionnez Modifier dans le menu contextuel. Le dialogue Style de cadre s’ouvre.

5) Cliquez sur l’onglet Adaptation du texte. Modifiez à 0 les valeurs pour À gauche et À droite 
dans la section Espacement.

6) Cliquez sur OK pour fermer le dialogue.

Ceci permet de changer l’espacement pour toutes les formules qui n’ont pas leur espacement 
modifié manuellement. Pour plus de détails sur comment utiliser les styles, voir la section Mise en
forme par défaut avec style page 25.

Mode Texte
Les grandes formules doivent toujours être dans leur propre paragraphe, séparées du reste du 
texte. Lors de l’emploi d’éléments de formule dans le cœur du texte, ils risquent souvent d’être plus 
grand que la hauteur du texte. 

Cependant, s’il est nécessaire de placer une formule dans le cœur du texte, entrez dans l’éditeur 
d’équation et sélectionnez le mode Format > Mode Texte. Math essaiera de réduire la taille de la 
formule pour correspondre à la hauteur du texte. Les numérateurs et dénominateurs de fractions 
sont  réduits  et  les  limites  des  intégrales  et  des  sommes  sont  placées  à  côté  du  signe 
intégrale/somme.

Exemple :
Une formule dans un paragraphe séparé :

∑
i=2

5

i2

et la même formule insérée en mode texte : ∑i=2
5 i2
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Arrière-plan, bordures et taille
À propos du formatage, les formules sont traitées comme des objets de type cadre utilisant le style 
de cadre Formule. La couleur d’arrière-plan et les bordures peuvent être choisies à l’aide du style 
ou modifiées manuellement pour chaque formule par le menu Format > Cadre/Objet, ou par clic-
droit sur la formule et sélection de Objet dans le menu contextuel. Par défaut les formules ont un 
arrière-plan  transparent  et  pas  de  bordure.  La  taille  des  formules  ne  peut  pas  être  modifiée 
directement : dans Writer cela dépend directement de la façon dont la formule a été construite (voir 
Modifier la taille de police page 17).

Créer une bibliothèque de formules
Si vous utilisez le module Math de LibreOffice directement avec Fichier > Nouveau > Formule, 
vous créez des documents avec le suffixe .odf (OpenDocument Formula), chacun contenant une 
seule formule. Vous pouvez les utiliser pour vous constituer une bibliothèque des formules les plus 
utilisées. Les formules insérées dans un document peuvent également être enregistrées comme 
des documents Math séparés en cliquant-droit sur la formule et en sélectionnant dans le menu 
contextuel Enregistrer la copie sous. Pour insérer un document Math dans un document Writer, 
sélectionnez le menu  Insertion > Objet > Objet OLE. Sélectionnez l’option  Créer à partir d’un 
fichier  et entrez le chemin du fichier ou cliquez sur le bouton  Rechercher pour parcourir votre 
système de fichiers.

Note
Vous ne pouvez pas insérer le document par glisser-déposer avec la souris, ni à 
l’aide du menu Insertion > Fichier.

Les formules ne peuvent pas être stockées dans la Gallery car elles ne sont pas dans un format 
graphique.  Vous  pouvez  cependant  enregistrer  une  formule  en  tant  qu’AutoTexte.  Écrivez  la 
formule  dans  un  paragraphe  séparé,  sélectionnez-la,  et  sélectionnez  le  menu  Édition  > 
AutoTexte.  Pour  plus  d’information,  reportez-vous  à  la  section  Utilisation  des  AutoTextes du 
chapitre 3 du Guide Writer (Travail avec du texte).

Insertion rapide de formule
Si vous connaissez le balisage de votre formule, une méthode rapide pour l’insérer consiste à :

• écrire le code de la formule dans Writer,

• sélectionner ce code,

• appeler l’insertion de formule aussi bien par le bouton que par le menu ou le raccourci 
clavier. 

Ceci évite l’ouverture des fenêtres d’insertion de formule et permet un gain de temps correct.

Personnalisations

Personnaliser le catalogue
Si vous avez besoin d’un symbole qui n’est pas disponible dans Math, vous pouvez l’ajouter vous-
même au catalogue. L’exemple suivant montre la procédure :

1) Sélectionnez le menu Outils > Catalogue ou cliquez sur le bouton du catalogue  pour 
ouvrir le catalogue de symboles (Figure 8).

2) Cliquez sur le bouton Éditer. La fenêtre d’Édition des symboles (Figure 20) s’ouvre.
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3) Les symboles sont organisés en jeux de symboles. Dans la partie basse de la fenêtre, 
sélectionnez un jeu disponible  pour  votre nouveau symbole dans la  liste des  Jeux de 
symboles,  par  exemple  le  jeu  Spécial.  Ou  vous  pouvez  taper  directement  le  nom  du 
nouveau jeu de symboles dans la boite.

4) Dans la liste des Polices, sélectionnez la police contenant le symbole souhaité.

Lorsque vous avez sélectionné une police, ses caractères apparaissent dans la fenêtre 
d’aperçu de la police. Vous pouvez la parcourir  à l’aide de l’ascenseur sur le côté,  ou 
utiliser la liste Plage pour aller directement à l’endroit recherché. 

Pour  suivre  cet  exemple,  sélectionnez  la  police  DejaVu Sans et  la  plage  Ponctuation 
générale.

5) Cliquez sur le symbole souhaité (ici Ux2032). Il apparaît agrandi dans la boite d’aperçu à 
l’extrême droite (Figure 21). Assurez-vous que le jeu de symboles est Spécial.

6) Dans le champ Symbole, entrez un nom pour le symbole, par exemple prime.

7) Si le nom n’est pas utilisé actuellement, le bouton Ajouter devient actif. Cliquez dessus.

8) Vous  pouvez  immédiatement  ajouter  d’autres  symboles.  Pour  l’exemple,  les  symboles 
U+2033, nommé dblprime, et U+2034, nommé triprime, sont ajoutés (Figure 22).

9) Cliquez sur OK pour fermer le dialogue.

Figure 20 : Dialogue d’édition des symboles

Figure 21 : Dialogue d’édition des symboles : nommage du nouveau symbole
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Maintenant la zone d’aperçu du jeu de symboles montre les nouveaux symboles. Ils peuvent être 
sélectionnés comme les autres symboles, soit à partir de ce dialogue, soit en écrivant directement 
leur nom dans l’éditeur d’équation sous la forme %prime.

Il y a de nombreuses polices gratuites contenant un grand nombre de symboles mathématiques. 
La police STIX2 mérite  une attention particulière ici.  Elle a été développée spécialement pour 
écrire  des  textes  mathématiques  et  techniques.  Les  polices  DejaVu3 et  Lucida4 disposent 
également d’une large gamme de symboles.

Attention
Contrairement aux commandes, les symboles (grecs ou spéciaux) doivent respecter 
la casse (majuscule/minuscule) pour être reconnus.

Figure 22 : Catalogue Spécial avec les nouveaux symboles

Note
Beaucoup de symboles sont disponibles dans plus d’une police. Si vous échangez 
des documents, faîtes attention d’utiliser une police installée sur les machines de 
vos partenaires. 

Dans la configuration par défaut de LibreOffice, seuls les symboles définis par l’utilisateur qui sont 
effectivement utilisés dans le document, sont stockés avec lui. Parfois il peut être utile d’inclure 
tous les symboles définis par l’utilisateur, par exemple quand le document va être édité par la suite 
par une autre personne. Sélectionnez Outils > Options > LibreOffice Math > Paramétrages, et 
décochez l’option  Incorporer uniquement les symboles utilisés (taille de fichier inférieure). 
Ce  paramétrage  est  uniquement  accessible  lors  de  l’utilisation  de  Math  comme  module 
indépendant.

Mise en forme par défaut avec style
Dans  Writer,  les  formules  sont  mises  en  forme  en 
suivant le style de cadre  Formule. Dans la fenêtre du 
styliste  (affichage  par  F11),  cliquez  sur  le  3e bouton 
Styles  de  cadre.  Cliquez  droit  sur  Formule et 
sélectionnez  Modifier.  Vous  pouvez  modifier  ainsi 

2 Les fichiers pour la police STIX sont disponibles sur http://www.stixfonts.org 
3 Les fichiers de la police DejaVu Sans sont disponibles sur http://www.dejavu-fonts.org 
4 Lucida Sans est inclus dans le paquet JRE, qui est probablement déjà sur l’ordinateur.
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directement  toutes  les  formules  du document  en ce qui  concerne l’espacement  (page  22)  ou 
l’arrière-plan (page 23), sauf si vous avez modifié le format manuellement.

Pour que cette mise en forme soit appliquée à tous les nouveaux documents Writer, vous devez 
intégrer le style  Formule dans le modèle par défaut. Pour cela, créez un nouveau document et 
modifiez le style  Formule comme souhaité. Enregistrez le document par  Fichier > Modèles > 
Enregistrer. Pour le définir comme modèle par défaut, sélectionnez Fichier > Modèles > Gérer ; 
double-cliquez sur  Mes modèles : votre modèle doit apparaître juste en dessous. Cliquez droit 
dessus et sélectionnez  Définir comme modèle par défaut. La commande  Rétablir le modèle 
par défaut, permet de revenir au modèle par défaut fourni lors de l’installation de LibO.

Les nouveaux documents texte suivront ce modèle.

Application aux formules chimiques
Math a été conçu pour écrire des formules mathématiques, mais il peut aussi servir à écrire des 
formules chimiques. En chimie,  les formules ressemblent à H2O : les noms des éléments sont 
habituellement en majuscule droite. Pour écrire les formules chimiques avec  Math vous pouvez 
commencer en sélectionnant le style droit pour les variables (voir Modifier la police page 18).

Voici quelques exemples de formules chimiques :

Construction Exemple Entrée

Molécules H2 SO4 H_2 SO_4 (notez l’espace !)

Isotopes U92
238 U lsub 92 lsup 238

Ions SO4
2− SO_4^{2-{}} ou SO_4^{2"-"}

Notes :  lsub ou  lsup sont les abréviations de  left subscript et left superscript.  Les accolades 
vides après 2- sont nécessaires pour éviter une erreur car il n’y a pas de membre après le moins.

Pour les réactions chimiques réversibles, il n’y a pas de double flèches satisfaisantes dans Math. 
Si vous disposez d’une police de caractères comportant un symbole satisfaisant,  vous pouvez 
utiliser la méthode décrite à la section Personnaliser le catalogue page 23. Par exemple les polices 
DejaVu comportent les doubles flèches ⇄ ⇆ ⇋ ⇌.

Sinon, il faut récupérer le caractère spécial d’un document et le copier, par exemple à partir de 
cette  formule :  C+O⇌CO  "⇌".  Vous  trouverez  d’autres  double  flèches  sur 
http://dev.w3.org/html5/html-author/charref à partir du caractère x021C4.

Commandes Math – Référence

La liste complète des commandes et mots réservés de Math est disponible en annexe du Guide 
Math :

• Opérateurs unaires / binaires

• Relations

• Opérateurs d’ensemble

• Fonctions

• Opérateurs

• Attributs

• Parenthèses

• Formats

• Autres

• Caractères grecs

• Caractères spéciaux

• Mots réservés par ordre alphabétique
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